Results 1 to 5 of 5

Thread: Rear turn signals and brake lights don't work.

  1. #1

    Rear turn signals and brake lights don't work.

    I have a 91 K5. Found out the brake lights and rear turn signals aren't working. The front turn signals work and the dash indicators work. I checked the fuses, all good. I checked the bulbs, they're good too! Any suggestions?

  2. #2
    Need to win Power Ball. Senior member AV8TER's Avatar
    Join Date
    Jun 2013
    Location
    Southwest Oregon
    Posts
    2,373
    Quote Originally Posted by chuck's91 View Post
    I have a 91 K5. Found out the brake lights and rear turn signals aren't working. The front turn signals work and the dash indicators work. I checked the fuses, all good. I checked the bulbs, they're good too! Any suggestions?
    Both sides out? Do tail lights work? If tail lights work, you may have a problem with the turn signal switch on steering column. The brake light wire goes thru the turn switch so it can turn off the brake light and make it flash for turn. Or could be wires running to the back. There may be a plug or two down the line to the tail lights. I've never had to look at mine.

    I don't always drive a 4x4, but when I do, it's a Chevy.

    1984. HO 454, EFI, 700R4, 208, D44, shaved 14FF, both locked.
    4 in lift. 35 inch Toyo MTs.
    AKA The Trail Master 3000
    October 2014 TOTM

    The only thing funner than a big engine is a bigger engine!!!

  3. #3
    Quote Originally Posted by AV8TER View Post
    Both sides out? Do tail lights work? If tail lights work, you may have a problem with the turn signal switch on steering column. The brake light wire goes thru the turn switch so it can turn off the brake light and make it flash for turn. Or could be wires running to the back. There may be a plug or two down the line to the tail lights. I've never had to look at mine.
    Both sides are out. The tail lights still work.

  4. #4
    Damage case Senior member junkyard dog's Avatar
    Join Date
    Sep 2010
    Location
    in the junkyard or st helens or
    Posts
    4,054
    sounds like what mine was doing... it was a bad connection on the turn signal switch....replaced it and problem solved
    1981 blazer- the junkyard dog...FOR SALE

    90 ford ranger-daily driver

  5. #5
    Quote Originally Posted by junkyard dog View Post
    sounds like what mine was doing... it was a bad connection on the turn signal switch....replaced it and problem solved
    Thanks for the info. Gives me a place to start.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •