Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Runs rough then shuts off at adle,let it sit and runs ok for a few minutes???

  1. #1
    Shadetree Mechanic Chico SYLO's Avatar
    Join Date
    May 2011
    Location
    Brunswick,Ga
    Posts
    212

    Runs rough then shuts off at adle,let it sit and runs ok for a few minutes???

    OK, Here is the situation.

    I was low on gas,put a half of tank of fuel in it. About five miles later It started running rough,very weak. When I came to a stop it got worse and then shut off. Re started and the same thing. If i wait a few minutes to re-start it runs ok then gets rough again and shuts off at an idle.

    Any help? I was thinking maybe the fuel filter. Anyone with a similar problem??

    Thanks

    1990 Blazer Silverado 4x4
    350/700R4
    Dual Flowmaster Exhaust
    6" Suspension~2" Body~35" tires~15x12 Mickey Thompson Rims
    Alpine deck~MTX amp~ 2=12" Kicker Subs~Python Alarm
    CB~ClassIII Hitch~Electric Brake~KC Lights

  2. #2
    $6Million man in progress Senior member Timberdoodles's Avatar
    Join Date
    Jul 2010
    Location
    Shawnee, KS
    Posts
    7,182
    That would be a good place to start! Has it ever been changed before?
    Don't confuse my personality with my attitude. My personality is who I am, my attitude depends on who you are!

    "Ability", is What you are capable of doing. "Motivation", determines what you do. "Attitude" defines how "well" you do it! There is no sense in doing anything, if you can't do it right! Do it right the first time, because, when will you have time to do it again?

    Intarsia Album Art

  3. #3
    The Green Machine Shadetree Mechanic 874x480's Avatar
    Join Date
    Oct 2010
    Posts
    161
    I SEE YOU HAVE A PIC OF REAR SEAT IS THAT A COVER OR DID YOU HAVE IT DONE

  4. #4
    Knows their $hit 84_K5's Avatar
    Join Date
    Jul 2010
    Location
    Florida
    Posts
    919
    I would start with the fuel filter... you could have picked up a bunch of trash running low on gas.


    84 K5 - Newer front clip
    350/ 350 Turbo/ NP 205
    6in Skyjacker on 35in Goodyear MTR
    Everything pretty much new
    Hundreds of hours in time and thousands of dollars wasted....

    My build thread - http://www.chevyk5blazer.com/forums/...4-K5-money-pit

  5. #5
    Shadetree Mechanic Chico SYLO's Avatar
    Join Date
    May 2011
    Location
    Brunswick,Ga
    Posts
    212
    OK,just changed out the fuel filter. It does run now..almost like surging.. I got a pint of seafoam and poured it in there and just letting it idle. Seems to be working it out. Not perfect though. As for the rear seat and the front one's. They are not seat covers.

    Thanks guys and I keep you posted. Thinking about topping the tank off with 89 fuel and see if that would help.

    1990 Blazer Silverado 4x4
    350/700R4
    Dual Flowmaster Exhaust
    6" Suspension~2" Body~35" tires~15x12 Mickey Thompson Rims
    Alpine deck~MTX amp~ 2=12" Kicker Subs~Python Alarm
    CB~ClassIII Hitch~Electric Brake~KC Lights

  6. #6
    Knows their $hit 84_K5's Avatar
    Join Date
    Jul 2010
    Location
    Florida
    Posts
    919
    go take it for a hard drive... see if it clears up. Probably was the fuel filter. I never run my tank much below 1/4 of a tank....and I have a brand new gas tank.
    You guys that have an orginial tank or older one.. I would never go below 1/4 or 1/8 for sure.


    84 K5 - Newer front clip
    350/ 350 Turbo/ NP 205
    6in Skyjacker on 35in Goodyear MTR
    Everything pretty much new
    Hundreds of hours in time and thousands of dollars wasted....

    My build thread - http://www.chevyk5blazer.com/forums/...4-K5-money-pit

  7. #7
    Knows their $hit 84_K5's Avatar
    Join Date
    Jul 2010
    Location
    Florida
    Posts
    919
    if it still runs like junk.. I would drop the tank... check the sock at the bottom of the fuel pump...could be clogged. Also check the little rubber hose on the fuel pump.. make sure it's good and tight and not leaking. Clean the tank out while you have it down.


    84 K5 - Newer front clip
    350/ 350 Turbo/ NP 205
    6in Skyjacker on 35in Goodyear MTR
    Everything pretty much new
    Hundreds of hours in time and thousands of dollars wasted....

    My build thread - http://www.chevyk5blazer.com/forums/...4-K5-money-pit

  8. #8
    $6Million man in progress Senior member Timberdoodles's Avatar
    Join Date
    Jul 2010
    Location
    Shawnee, KS
    Posts
    7,182
    That tank has been in there for 20+ years, and has bound to have some rust and sediment settled to the bottom. Try not to let your tank get below 1/4, just to keep that crap out of the fuel pump!

    That is, unless you drop the tank and clean or replace it.
    Last edited by Timberdoodles; 01-11-2012 at 08:58 PM.
    Don't confuse my personality with my attitude. My personality is who I am, my attitude depends on who you are!

    "Ability", is What you are capable of doing. "Motivation", determines what you do. "Attitude" defines how "well" you do it! There is no sense in doing anything, if you can't do it right! Do it right the first time, because, when will you have time to do it again?

    Intarsia Album Art

  9. #9
    Shadetree Mechanic Chico SYLO's Avatar
    Join Date
    May 2011
    Location
    Brunswick,Ga
    Posts
    212
    Yea, I know better. It was just one of those days and I was trying to hurry and get somewhere. What a mistake. I think I'm just gonna drop the tank and clean it and check the sock. If I don't do it,it will always bother me...lol Thanks for all the help guys!!!!

    1990 Blazer Silverado 4x4
    350/700R4
    Dual Flowmaster Exhaust
    6" Suspension~2" Body~35" tires~15x12 Mickey Thompson Rims
    Alpine deck~MTX amp~ 2=12" Kicker Subs~Python Alarm
    CB~ClassIII Hitch~Electric Brake~KC Lights

  10. #10
    Shadetree Mechanic Chico SYLO's Avatar
    Join Date
    May 2011
    Location
    Brunswick,Ga
    Posts
    212
    I have a update.... I checked the trouble codes and 34 came up. Which is OR . i WENT AHEAD AND REPLACED THE MAP SENSOR...THE TRUCK RUNS GREAT! It through out a code a while back which was 32 OR
    Thanks again!!

    1990 Blazer Silverado 4x4
    350/700R4
    Dual Flowmaster Exhaust
    6" Suspension~2" Body~35" tires~15x12 Mickey Thompson Rims
    Alpine deck~MTX amp~ 2=12" Kicker Subs~Python Alarm
    CB~ClassIII Hitch~Electric Brake~KC Lights

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •